SymbOS 3.1

Textverarbeitung, Tabellenkalkulation, Datenbank, ...
Antworten
Benutzeravatar
schombi
Beiträge: 116
Registriert: 09.02.2015, 19:19

SymbOS 3.1

Beitrag von schombi »

Hat jemand schon die neue Version 3.1 von SymbOS ausprobiert?
http://www.symbos.de/download.htm
My beloved residents:
http://schombi.de/my-retro-collection.html
kurt
Beiträge: 81
Registriert: 26.10.2019, 20:11

Re: SymbOS 3.1

Beitrag von kurt »

Nein, dafür ist es denn doch zu frisch :)

Der letzte Versuch war mit der 2.1 Version. Mich konnte die wegen der asymetrischen Pixel deutlich verzerrte Darstellung nicht so überzeugen. Aber es wäre einen erneuten Versuch wert. :D
wnb
Beiträge: 52
Registriert: 06.03.2015, 12:16
Wohnort: Werner aus Wolfhagen

Re: SymbOS 3.1

Beitrag von wnb »

.
Vor vielen (!) Jahren gab es eine Version, die wir nur auf dem Emulator von John Elliott und nicht auf einem realen JOYCE zum Laufen bekamen. Unsere eMails an den Autor blieben seinerzeit leider unbeantwortet. Später habe ich dann bei diversen Treffen auch `mal einen realen JOYCE gesehen, auf dem SymbOS lief (z.B. Mahlerts ... oder war's dort eine CPC ?) und auch ein weiterer offizieller Kontaktversuch der JUAG zum Autor blieb unbeantwortet, so habe ich persönlich mein Interesse verloren :?
.
Aber ich freue mich über jede "Erweiterung" für unseren JOYCE. Falls Ihr SymbOS v3.1 testet, würde ich mich über einen Bericht für die Klubzeitung freuen :) Vielleicht kennt jemand von Euch "Prodaton" persönlich: Unser Angebot, dass wir seine Software in unserer Klubzeitung vorstellen oder auch über unsere Homepage verlinken, gilt immer noch ;)

.
Benutzeravatar
schombi
Beiträge: 116
Registriert: 09.02.2015, 19:19

Re: SymbOS 3.1

Beitrag von schombi »

Also, ich erinnere mich ebenfalls vor vielen Jahren mal SymbOS auf meinem echten PCW ausprobiert zu haben. Das ist aber sicher 6 Jahre her. Ich war auch kurz in Kontakt mit Prodatron. Dieser ist Mitglied im Verein zum Erhalt klassicher Computer. Lt. VzEkC Homepage, ist er ab und an im Forum dort (zuletzt im Dezember 2021), aber im Vergleich zu früher wohl eher als stiller Mitleser. Ich hatte ihn damals zu einem möglichen Port auf Spectrum 128 oder SAM Coupe gefragt, aber er war nicht sehr begeistert (ich meine es war wegen des Bankswitchings).
My beloved residents:
http://schombi.de/my-retro-collection.html
kurt
Beiträge: 81
Registriert: 26.10.2019, 20:11

Re: SymbOS 3.1

Beitrag von kurt »

Da meine Joyce nun ja einsatzbereit ist, habe ich u. a. auch SymbOS-3.1 ausprobiert - wegen der Maus. Das OS zu "installieren", war mehr als einfach. Auf Laufwerk-A das Boot-Image, auf B den Rest und das Zeug von A !. Starten muß man es dann über B. Weshalb a u. B ? Weil das OS beim Start von A seine Aps nicht findet, auf B wird zumindest so wie ich es installiert habe nicht gesucht. Start von B wird der Desktop-Hintergrund von A geladen, auch wenn er auf B zu finden ist (und u. U. auch noch anderes, was kann ich nicht sagen). Soweit zumindst ales gut... Die Apps kann ich nicht starten, da sie angeblich nicht gefunden werden, die Icons werden aber treu angezeigt !? Das läßt sich ev. ändern, wenn mein Laufwerk-A 720kB groß wäre - ist es aber z. Zt. noch nicht.

Mein Problem kommt jetzt ins Spiel: die Maus. Die Bedienung erfolgt vorerst über die Tastatur, da... eine vorhandene PS2-Maus nicht erkannt wird - trotz PCW-IO. Vermutlich muß dazu im Controll-Feld etwas eingestelt werden, geht aber nicht,weil s. oben. Ein weiteres Handycap ist, das die KeyMaus-Emulation der PCW-IO anscheinend erhebliche Probleme mit den heuzutage vorhanden PS2-Mäusen zu haben scheint. Unter DESKJOY für CPM gelang es mir nur unter erheblichen Schwierigkeiten 2 von 3 Mäusen zum Laufen zu bringen (auch scheint die Beschreibung von Habi-Soft zur Karte im Wiki veraltet/unvollständig zu sein) und das nur mit deutlichen Bedienungsproblemen (bei 1000dpi gelangt der PIC wohl an seine Software-Grenzen, bis hin zum Totalhänger). Jedenfalls ist unter SymbOS ohne Maus kein zurechtkommen. Eine andere Frage an die Runde zur Tastatur/PCW-IO: Je länger ich mit meinem System spiele, umso deutlicher werden Power-ON/Initialisierungsprobleme des PIC bei unterschiedlichen PS2-Tastaturen, ev. auch bei den Mäusen. An- und abstecken nach dem Einschalten ist tabu, Mäuse MÜSSEN so scheint es angestopselt sein, ansonsten werden sie garantiert nicht erkannt, bei der Tastatur klappt das in 50:50 der Fälle (hängt aber auch von der benutzten Tastatur ab). Gibt es womöglich schon ältere Erfahrungen mit Habi-Softs Original-PCW-IO hierzu ? Momentan geht mein Verdacht in Richtung Brown-Out u. Startup-Timer, das erstere u. ev. auch letzterer doch benötigt werden, um genannte Probleme durch Einschalten und hochlaufen der 5V-Versorgung zu vermeiden (vllt. kann ich das dieses Wochenende noch testen). Alles so Dinge, die immer erst hochkommen, wenn die passende Anwendung ins Rampenlicht tritt...

Mal abgesehen von den Problemen vorm Bildschirm, ist soweit testbar das OS völlig ok und eigentlich super. Es lohnt sich sicher, weiter in die Nutzung einzusteigen - aber nur mit Maus.
Benutzeravatar
schombi
Beiträge: 116
Registriert: 09.02.2015, 19:19

Re: SymbOS 3.1

Beitrag von schombi »

Danke für den Bericht. Ich will das auch unbedingt mal live sehen, aktuell liegt die Joyce aber mit offenem Herzen auf dem OP-Tisch - ich komme - Job sei Dank - zu fast gar nichts.
My beloved residents:
http://schombi.de/my-retro-collection.html
Antworten